Cassandra connector returns no data

Post questions here relative to DataStage Enterprise/PX Edition for such areas as Parallel job design, Parallel datasets, BuildOps, Wrappers, etc.

Moderators: chulett, rschirm, roy

Post Reply
Posts: 5
Joined: Thu Dec 13, 2018 6:11 pm

Cassandra connector returns no data

Post by lkevin1210 »

I have DataStage installed on my RHEL 7 machine, and DataStax Enterprise cassandra 6.0.8 installed on another RHEL 7 machine with single node configuration, then I created a keyspace and table, and inserted a few rows to the table for testing.

Following the guide from ibm developer here. After copying the jar drivers, I tried to use the cassandra connector, it runs without any error, the job is as simple as below:
Cassandra connector ---> Peek

However, the cassandra connector stage has 0 row output to the peek stage, I wonder are there any additional parameters/configurations needed to be set in the DataStage server/cassandra server? :roll:

Also has anyone has experienced similar issue before? Thanks in advance. :D

Update (2019-06-27): I have installed Apache cassandra in another VMs (2 nodes configuration), using Cassandra connector to connect to the apache cassandra VMs works just fine and there is data returning, but still no luck when connecting DataStax enterprise cassandra.
Post Reply