DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message

since June 2006

Group memberships:
Premium Members

Joined: 27 Mar 2006
Posts: 123
Location: San Ramon
Points: 1588

Post Posted: Thu Jan 12, 2017 7:37 pm Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Parallel
OS: Unix
Additional info: on RedHat Linux
We're on Info Server on RedHat Linux.

We have a simple job writing to the unstructured data stage (excel file as output). If we use the defaults in the unstructured stage, only specifying the output file (path and file name) the job completes successfully without errors or warnings. However, if we specify "adjust column width" to "yes", then the job fails with the following odd error:

Unstructured_Data_4,0: Java runtime exception occurred: java.lang.InternalError: Can't connect to X11 window server using 'localhost:10.0' as the value of the DISPLAY variable. (sun.awt.X11GraphicsEnvironment::initDisplay, file X11GraphicsEnvironment.java, line -2)

Why would the job even be trying to open an X11 window in the first place? Any ideas?

The IBM online documentation doesn't mention any details beyond the basics.

I see this technote about WAS needing to set the DISPLAY variable, but I don't understand why this would be necessary for running a DataStage job in the first place.

Joined: 27 Feb 2016
Posts: 15
Location: Ottawa
Points: 207

Post Posted: Tue Jan 24, 2017 2:44 pm Reply with quote    Back to top    

For some reason, a jar is being executed which is attempting to connect to a X server. You can diagnose this in a couple of ways - check to see if the DISPLAY environment variable is set in the shell that launches Datastage Director or Designer.
Try running the job from the command line to see if the same error is reproduced - likely not.

A more involved scenario - when your job starts, check to see if a related java VM is launched and if possible try to find out the script that launches java and try to re-launch the same jar with -Djava.awt.headless=true


ETL, DW, BI Consultant
Rate this response:  

Joined: 08 May 2014
Posts: 32

Points: 379

Post Posted: Sun Jun 11, 2017 10:20 pm Reply with quote    Back to top    

Just going through the forum and found this which says exactly the same error as mine. But its un-resolved.

Do anybody have something to add to it ?
Rate this response:  

Premium Poster

since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 42836
Location: Denver, CO
Points: 220819

Post Posted: Mon Jun 12, 2017 6:33 am Reply with quote    Back to top    

Smells like a bug to me, have you involved your official support provider?


Your brain is full of spiders, you've got garlic in your soul, Mr. Grinch!
I wouldn't touch you With a thirty-nine-and-a-half foot pole!
Rate this response:  
Lamont Lockwood

Group memberships:
Premium Members

Joined: 11 Jan 2002
Posts: 3

Points: 25

Post Posted: Sat Feb 03, 2018 9:07 pm Reply with quote    Back to top    

Check your job log environment to see if DISPLAY is set. I received the same error, but it went away when I added "unset DISPLAY" to dsenv.

Rate this response:  
Not yet rated

Group memberships:
Premium Members

Joined: 21 Mar 2016
Posts: 338

Points: 3409

Post Posted: Mon Feb 05, 2018 10:49 am Reply with quote    Back to top    

We had similar problems with java issues and errors like this until we patched. this was for 11.5. Once patched, the problems just went away. Make sure you are up to date?

We are also on redhat etc.
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours