DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
ktrogers
Participant



Joined: 27 Sep 2016
Posts: 8
Location: Albuquerque, NM
Points: 114

Post Posted: Tue Sep 27, 2016 9:49 am Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Server
OS: Unix
We created several Data Rules for a project and these rules are setup to write the results to the same Advanced User-Named Table via the ‘Bindings and Output’ tab. At the time the rules were created, they were validated and returned no errors.
There are ~10 rules writing to the same Advanced User-Named table. When reviewing the results of the runs of these rules, the User-Named table only has the results for 3 of the result sets. The Data Rules do not throw any errors and are marked as completing successfully.
Looking for suggesting on how to troubleshoot this issue. Thanks in advanced.
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54407
Location: Sydney, Australia
Points: 295092

Post Posted: Tue Sep 27, 2016 5:12 pm Reply with quote    Back to top    

Welcome aboard.

Are you generating the same unique IDs for the rules, and thereby overwriting rows in your table?

_________________
RXP Services Ltd
Melbourne | Canberra | Sydney | Hong Kong | Hobart | Brisbane
currently hiring: Canberra, Sydney and Melbourne (especially seeking good business analysts)
Rate this response:  
Not yet rated
ktrogers
Participant



Joined: 27 Sep 2016
Posts: 8
Location: Albuquerque, NM
Points: 114

Post Posted: Wed Sep 28, 2016 3:22 pm Reply with quote    Back to top    

When you say unique ID's what are you referring to? Each rule has a unique name. When selecting the data to be stored in the Name-User table, I am selecting SystemDate, RuleExecutableName, RuleMetOrNotMet, then the key to the table and the field being analyzed.

I do not see on any of the screen setting the unique ID.
Rate this response:  
Not yet rated
rjdickson
Participant



Joined: 16 Jun 2003
Posts: 378
Location: Chicago, USA
Points: 2531

Post Posted: Wed Oct 12, 2016 6:12 am Reply with quote    Back to top    

Did you select 'append' for them all, or are some 'create'? You need to make sure you run the 'create' one first...

_________________
Regards,
Robert
Rate this response:  
Not yet rated
rjdickson
Participant



Joined: 16 Jun 2003
Posts: 378
Location: Chicago, USA
Points: 2531

Post Posted: Wed Oct 12, 2016 6:13 am Reply with quote    Back to top    

Did you select 'append' for them all, or are some 'create'? You need to make sure you run the 'create' one first...

_________________
Regards,
Robert
Rate this response:  
Not yet rated
ktrogers
Participant



Joined: 27 Sep 2016
Posts: 8
Location: Albuquerque, NM
Points: 114

Post Posted: Mon Oct 24, 2016 2:38 pm Reply with quote    Back to top    

All the rules are using 'Append'
Rate this response:  
Not yet rated
truenorth
Participant



Joined: 18 Jan 2010
Posts: 129
Location: San Antonio
Points: 866

Post Posted: Fri Jul 21, 2017 1:50 pm Reply with quote    Back to top    

Go to Project Properties and check your settings for purging rule output tables.

_________________
Todd Ramirez
Sr Consultant, Data Quality
San Antonio TX
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours