DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
This topic has been marked "Resolved."
Author Message
deboots



Group memberships:
Premium Members

Joined: 23 Feb 2012
Posts: 71
Location: Portland, OR
Points: 777

Post Posted: Thu Jul 19, 2012 11:48 am Reply with quote    Back to top    

DataStage® Release: 8x
Job Type: Server
OS: Unix
We have just hooked Cognos up to Business Glossary and are having a few challenges. Hooking Cognos to Business Glossary was an easy configuration entry change (other posts here describe that process). When you do this, a consumer viewing a report can right click on a report label and then select the 'Glossary' menu option. That performs a search in Business Glossary for that report label as a term and returns a list of relevant terms.

This works well unless the term contains a % sign. Does anyone know if special characters are not allowed in Cognos report labels if they will be used as a search parameter to Business Glossary? What is that list not allowed?

More specifics for those still interested: I have 'Grant %' and 'Grant Funded Amt' as terms in Business Glossary. However, from a report whe I selet Glossary for 'Grant Funded Amt' it works and shows a list of terms. Grant Funded Amt is at the top of that list but Grant % is also within the list (because it does an advanced search - somthing else I'd love to change!). However, when I select Glossary for 'Grant %' directly - a blank screen is returned. When a term is not in the Glossary it will return a screen with a message saying 'no items met the search criteria'. So I think there is something about the percent sign that is messing it up.


Thanks much!
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54431
Location: Sydney, Australia
Points: 295208

Post Posted: Thu Jul 19, 2012 3:07 pm Reply with quote    Back to top    

I think so too. What does your official support provider advise?

_________________
RXP Services Ltd
Melbourne | Canberra | Sydney | Hong Kong | Hobart | Brisbane
currently hiring: Canberra, Sydney and Melbourne (especially seeking good business analysts)
Rate this response:  
eostic

Premium Poster



Group memberships:
Premium Members

Joined: 17 Oct 2005
Posts: 3794

Points: 30536

Post Posted: Thu Jul 19, 2012 7:38 pm Reply with quote    Back to top    

I haven't found a way to change the search logic that is inside of cognos.....but some accounts have chosen to write their own search widgets for their browser using the REST API, to customize the sea ...

_________________
Ernie Ostic

blogit!
Open IGC is Here!
Rate this response:  
vmcburney

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup

Joined: 23 Jan 2003
Posts: 3590
Location: Australia, Melbourne
Points: 28109

Post Posted: Sun Jul 22, 2012 8:08 am Reply with quote    Back to top    

There is a Developerworks article about writing your own term finder widget that can be used from Cognos:
http://www.ibm.com/developerworks/data/library/techarticle/dm-0909infosphererest/ .

_________________
Certus Solutions
Blog: Tooling Around in the InfoSphere
Twitter: @vmcburney
LinkedIn: Vincent McBurney LinkedIn
Rate this response:  
Not yet rated
deboots



Group memberships:
Premium Members

Joined: 23 Feb 2012
Posts: 71
Location: Portland, OR
Points: 777

Post Posted: Tue Jul 31, 2012 10:18 am Reply with quote    Back to top    

I did log a Service Request with IBM. They have agreed this as a problem and are looking at what needs to be done. Either the documentation for 8.7 needs to say not to use special characters (it doesn't now) or the % sign needs to not throw a wrench.

I believe you can track the progress on this as well if you have access to the IBM Service Request system. The # is:

Service request number
44403 550 000
Rate this response:  
Not yet rated
deboots



Group memberships:
Premium Members

Joined: 23 Feb 2012
Posts: 71
Location: Portland, OR
Points: 777

Post Posted: Thu Sep 06, 2012 3:37 pm Reply with quote    Back to top    

Hey - Was just notified by IBM regarding my PMR 44536,550,000.
The engineering team has completed the patch and they gave me the URL for download. If you are having this same problem - where the call from Cognos to the BG won't return the term if it contains a special character (like a % in my situation) - you should contact IBM to request the patch.
Rate this response:  
Not yet rated
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54431
Location: Sydney, Australia
Points: 295208

Post Posted: Thu Sep 06, 2012 9:17 pm Reply with quote    Back to top    

So, resolved now? Not too bad a turnaround time to produce a patch.

_________________
RXP Services Ltd
Melbourne | Canberra | Sydney | Hong Kong | Hobart | Brisbane
currently hiring: Canberra, Sydney and Melbourne (especially seeking good business analysts)
Rate this response:  
Not yet rated
deboots



Group memberships:
Premium Members

Joined: 23 Feb 2012
Posts: 71
Location: Portland, OR
Points: 777

Post Posted: Fri Sep 14, 2012 4:34 pm Reply with quote    Back to top    

[quote="ray.wurlod"]So, resolved now? Not too bad a turnaround time to produce a patch.[/quote]

I know! A bit under 2 months. I feel really honored to have gotten that level of service.
Rate this response:  
Not yet rated
eostic

Premium Poster



Group memberships:
Premium Members

Joined: 17 Oct 2005
Posts: 3794

Points: 30536

Post Posted: Fri Sep 14, 2012 6:18 pm Reply with quote    Back to top    

I'm glad that was turned around as quickly as it was and that it is working for you. BG is experiencing a very strong adoption rate and that is reflected in this kind of activity. Governance is catc ...

_________________
Ernie Ostic

blogit!
Open IGC is Here!
Rate this response:  
Not yet rated
deboots



Group memberships:
Premium Members

Joined: 23 Feb 2012
Posts: 71
Location: Portland, OR
Points: 777

Post Posted: Wed Jan 30, 2013 6:17 pm Reply with quote    Back to top    

Took us a while to install the patch and test it. And even longer for me to get around to updating this posting.

The patch did fix the problem of having special characters as part of term names. I'm still recommending that we try to avoid using special characters in term names but % is the most common and doesn't cause problems anymore!
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours