DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
This topic has been marked "Resolved."
Author Message
rahul8055
Participant



Joined: 23 Jun 2010
Posts: 95

Points: 764

Post Posted: Thu Jul 01, 2010 10:07 am Reply with quote    Back to top    

DataStage® Release: 8x
Job Type: Parallel
OS: Windows
can anyone help me with this error,

Standardize_385: Unable to open control file ./RT_QS32/V0S385/Controls/CopyOfUSNAME.DCT for input, reason code 2
No such file or directory



thanks,
Rahul
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54535
Location: Sydney, Australia
Points: 295717

Post Posted: Thu Jul 01, 2010 10:57 am Reply with quote    Back to top    

Usually this message stems from failure to provision all files in the rule set.

_________________
IBM Software Services Group
Any contribution to this forum is my own opinion and does not necessarily reflect any position that IBM may hold.
Rate this response:  
rahul8055
Participant



Joined: 23 Jun 2010
Posts: 95

Points: 764

Post Posted: Thu Jul 01, 2010 11:25 am Reply with quote    Back to top    

ray.wurlod wrote:
Usually this message stems from failure to provision all files in the rule set. ...



Thanks Ray,
Yes it is the problem of provisioning....
I have this message

Unable to link rule file, CopyOfUSNAME1.UPO, file may need provisioning

How can I provision the file can you please help me with that?
Rate this response:  
Not yet rated
josh.guffey
Participant



Joined: 17 Apr 2008
Posts: 40
Location: Huntsville, AL
Points: 452

Post Posted: Thu Jul 01, 2010 11:42 am Reply with quote    Back to top    

Rahul,

If memory serves me correct, you should be able to right click on the rule set and select provision all.

Josh
Rate this response:  
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54535
Location: Sydney, Australia
Points: 295717

Post Posted: Thu Jul 01, 2010 11:43 am Reply with quote    Back to top    

Right click on the SET icon in the Repository toolbar and choose Provision All. Or, as you're selecting the rule set within a design you can do the same thing.

_________________
IBM Software Services Group
Any contribution to this forum is my own opinion and does not necessarily reflect any position that IBM may hold.
Rate this response:  
rahul8055
Participant



Joined: 23 Jun 2010
Posts: 95

Points: 764

Post Posted: Thu Jul 01, 2010 12:49 pm Reply with quote    Back to top    

josh.guffey wrote:
If memory serves me correct, you should be able to right click on the rule set and select provision all.

thank you JOSH its working now
Rate this response:  
Not yet rated
rahul8055
Participant



Joined: 23 Jun 2010
Posts: 95

Points: 764

Post Posted: Thu Jul 01, 2010 12:50 pm Reply with quote    Back to top    

ray.wurlod wrote:
Right click on the SET icon in the Repository toolbar and choose Provision All. Or, as you're selecting the rule set within a design you can do the same thing. ...

Thankyou RAY

No error now
Rate this response:  
Not yet rated
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54535
Location: Sydney, Australia
Points: 295717

Post Posted: Thu Jul 01, 2010 2:37 pm Reply with quote    Back to top    

Please mark this thread as Resolved using the green button at top.

_________________
IBM Software Services Group
Any contribution to this forum is my own opinion and does not necessarily reflect any position that IBM may hold.
Rate this response:  
Not yet rated
U
Participant



Joined: 17 Apr 2007
Posts: 225
Location: Singapore
Points: 2795

Post Posted: Thu Jun 19, 2014 5:42 pm Reply with quote    Back to top    

I experienced exactly this problem today, but provisioning the rule set did not solve the problem.

stanEmail: Unable to open control file ./RT_QS5/V0S17/Controls/FLTREMAIL.DCT for input, reason code 2
A file or directory in the path name does not exist.

Instead we had to delete the process from the Standardize stage and add it there afresh, then re-compile the job.

We deduce that this re-emplaces the control file on the engine machine.
Rate this response:  
Not yet rated
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54535
Location: Sydney, Australia
Points: 295717

Post Posted: Thu Jun 19, 2014 9:13 pm Reply with quote    Back to top    

Thanks for sharing that.

Were the output mappings left in place in the Standardize stage? (I believe they should have been.)

_________________
IBM Software Services Group
Any contribution to this forum is my own opinion and does not necessarily reflect any position that IBM may hold.
Rate this response:  
Not yet rated
Chennai01
Participant



Joined: 06 Nov 2014
Posts: 4

Points: 52

Post Posted: Thu Nov 06, 2014 12:35 am Reply with quote    Back to top    

Hi,

I have experienced the similar problem today.

We are using a shared container in a job which is performing the address validations and it has been called by the same parallel job multiple times. When i try to run the job, i am getitng the below error.

"Unable to link rule file, USADDR.SET, file may need provisioning"

I tried to do the provision all per the earlier comments and it hasn't worked.

Job worked when i use the shared container once. But when I use multiple times in the same job, it's throwing the above error. Please suggest.

Thanks
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours