DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
This topic has been marked "Resolved."
Author Message
Ramkrish2801
Participant



Joined: 05 Jun 2019
Posts: 2

Points: 25

Post Posted: Thu Jun 06, 2019 12:13 am Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Server
OS: Windows
Hi All,

I try to run a audit job in preprod env which is calling from a sequence.The whole job (fetching from source and loading it to the target)is running fine but in audit job am getting warning messages where the insertion is not happening.I am using DB2Connector as the source and target for all jobs.But by making the target as a file in the audit job,it is running fine without any warnings and insertion also happening,in-case of db2connector as a target am getting issue.

The warning from the director log:
Transformer_17: Statement INSERT INTO db2cods.ETL_AUDIT_TABLE(JOB_START_TIMESTAMP,JOB_END_TIMESTAMP,JOB_STATUS,ROW_ID,ETL_PROJECT_NAME,ETL_CATEGORY_NAME,ETL_JOB_NAME,SOURCE_TABLE_NAME,TARGET_TABLE_NAME,ROWS_PROCESSED,JOB_SCHEDULE_INFORMATION,SURROGATE_KEY) VALUES(?,?,?,?,?,?,?,?,?,?,?,?) failed to run.

followed by another warning is also logged:
Transformer_17: SQLExecute reported: SQLSTATE = 23502: Native Error Code = -407: Msg = [IBM][CLI Driver][DB2/AIX64] SQL0407N Assignment of a NULL value to a NOT NULL column "TBSPACEID=2, TABLEID=14, COLNO=11" is not allowed. SQLSTATE=23502

I also tried various things to solve this error like verified the tablename,tried running with manual query for insertion,tried changing the arraysize to 1 ,crosschecked with DDL.

NOTE:This audit job is running fine in dev and prod environment,in preprod only am getting this error.It also noted that it is happening after the migration from IIS8.5 to IIS11.7

Any help is appreciated.

Thanks a lot,
Ramakrishna
Ramkrish2801
Participant



Joined: 05 Jun 2019
Posts: 2

Points: 25

Post Posted: Thu Jun 06, 2019 3:07 am Reply with quote    Back to top    

Hi all,

My issue gets resolved,we recreated the table in database level it worked since there was some issue in the table database level

Thanks,
Ramakrishna C
Rate this response:  
Not yet rated
chulett

Premium Poster


since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 42959
Location: Denver, CO
Points: 221538

Post Posted: Thu Jun 06, 2019 11:02 am Reply with quote    Back to top    

Guessing the column was supposed to allow nulls... glad you got it sorted out, whatever the exact issue was.

_________________
-craig

Now I've got that feeling once again, I can't explain; you would not understand
this is now who I am. I have become comfortably numb.
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours