DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
alfonso93
Participant



Joined: 17 Jul 2017
Posts: 1

Points: 110

Post Posted: Mon Jul 17, 2017 2:36 pm Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Parallel
OS: Unix
I'm trying to consume a web service form a parallel job.

More specifically, I'm trying to consume the method GetListItems from a sharepoint WS

I'm using the DataStage Disigner, but the actual DS server is another computer in the company.

I use the Web Service Client stage, and i tried linking it to a peek stage, or a dataset stage, or a xml input stage, in order to see if it returns something.

But it keeps throwing the same error:

APT_CombinedOperatorController,0: Fatal Error: Fatal: 0026`:`com.ascentialsoftware.wsclient.ServiceInvocationException: Service invocation exception: <Fault xmlns="http://schemas.xmlsoap.org/soap/envelope/">
<faultcode xmlns="">HTTP</faultcode>
<faultstring xmlns="">(404)Not Found</faultstring>
<detail xmlns="">
<string>return code: 404
&lt;?xml version=&quot;1.0&quot; encoding=&quot;ISO-8859-1&quot;?&gt;
&lt;!DOCTYPE html PUBLIC &quot;-//W3C//DTD XHTML 1.0 Strict//EN&quot;
&quot;http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd&quot;&gt;
&lt;html xmlns=&quot;http://www.w3.org/1999/xhtml&quot; lang=&quot;en&quot; xml:lang=&quot;en&quot;&gt;
&lt;head&gt;
&lt;title&gt;SOMIS - Object not found!&lt;/title&gt;
&lt;link rev=&quot;made&quot; href=&quot;mailto:%5bno%20address%20given%5d&quot; /&gt;
&lt;style type=&quot;text/css&quot;&gt;&lt;!--/*--&gt;&lt;![CDATA[/*&gt;&lt;!--*/
body { color: #000000; background-color: #FFFFFF; }
a:link { color: #0000CC; }
p, address {margin-left: 3em;}
span {font-size: smaller;}
/*]]&gt;*/--&gt;&lt;/style&gt;
&lt;/head&gt;
&lt;body&gt;
&lt;h1&gt;SOMIS - Object not found!&lt;/h1&gt;
&lt;p&gt;
The requested URL was not found on this server.
If you entered the URL manually please check your
spelling and try again.
</string>
</detail>
</Fault>
at com.ascentialsoftware.wsclient.OperationCall.handleRemoteException(OperationCall.java:406)
at com.ascentialsoftware.wsclient.OperationCall.invoke(OperationCall.java:311)
at com.ascentialsoftware.wsclient.WebService.callServiceInternal(WebService.java:1685)
at com.ascentialsoftware.wsclient.WebService.callService(WebService.java:1591)
at com.ascentialsoftware.wsclient.WebService.callService(WebService.java:1544)
at com.ascentialsoftware.wspack.Transformer.process(Transformer.java:105)
at com.ascentialsoftware.jds.StageFactory.runStage(StageFactory.java:544)
at com.ascentialsoftware.jds.StageFactory.runTransformer(StageFactory.java:361)




I says that it is a "404 - Not Found" error, but it doesn't even mention what resource is the one being looked for.




I specified the proxy of the company
I tried with and without the SSL trust all servers option


Something wierd that's worth mentioning is that when I import the WSDL. And then I load the input arguments of the WS client stage.
Some mappings include a * in the XPATH

For instance the query parameter
/ns1:GetListItems/ns1:query/*/text()

Unless I remove that * I get an error:
/ns1:GetListItems/ns1:query/*/text()", invalid token; element or attribute name expected.

So I remove the *:
/ns1:GetListItems/ns1:query/text()

I have tested the WS from a local client and it does work.

Any idea how to overcome this error?
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours