DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
This topic has been marked "Resolved."
Author Message
MrBlack
Participant



Joined: 08 Aug 2012
Posts: 125

Points: 1546

Post Posted: Wed Feb 17, 2016 11:12 pm Reply with quote    Back to top    

DataStage® Release: 11x
Job Type: Server
OS: Unix
I was told that jobs designed in 11.3 will continue to run in 11.5. I've discovered that jobs designed with any of the deprecated OCI stages will not run. They compile but in the logs they throw a warning and abort.

Code:
Oracle OCI has been DEPRECATED
This deprecated stage is replaced by the Oracle Connector Stage
Using the Connector Migration Tool, jobs using this deprecated component can be converted to use the Oracle Connector
Attempting to Cleanup after ABORT was raised in stage


This interfering with the upgrade schedule I had planned out. I've opened a PMR with IBM but they're being slow to respond. So I thought I'd check to see if anyone has been able to run a job with a deprecated stage?

I'm ok not having the stages available on the palette and I know eventually jobs will need to be updated, but I was hoping to do the in-place upgrade while it's available instead of doing a migration as it's going to take a lot of time to go and modify jobs and I would like to make the other benefits of the 11.5 available sooner rather than later to my developers.
Mike



Group memberships:
Premium Members

Joined: 03 Mar 2002
Posts: 1011
Location: Omaha, NE
Points: 6517

Post Posted: Thu Feb 18, 2016 1:11 pm Reply with quote    Back to top    

Interesting.

Those stages have been deprecated since version 8.5, so it isn't surprising that they would disappear at some point.

Seems like the documentation could have been a little better at pointing out the deprecated stages change.

Per the release notes, only these 5 deprecated stages can still be added to the palette:
•Java™ Client
•Java Transformer
•Netezza® Enterprise
•ODBC Enterprise
•WebSphere® MQ

I would assume that all of the others are gone.

Mike
Rate this response:  
Not yet rated
rkashyap



Group memberships:
Premium Members

Joined: 02 Dec 2011
Posts: 498
Location: Richmond VA
Points: 4518

Post Posted: Thu Feb 18, 2016 6:14 pm Reply with quote    Back to top    

In addition to official release documentation, following blog post is quite informative ... What is New, Updated or Dropped in DataStage 11.5. See Excerpt
Quote:
DataStage 11.5 is also the first version that will not include the old DataStage database plug-in stages with following replacements:
    Dynamic RDBMS Stage: replaced by DRS Connector
    Oracle OCI, Oracle OCI Load: replaced by Oracle Connector
    Teradata API: replaced by Teradata Connector
    DB2 UDB Load, UBD API, DB2 Z: replaced by DB2 Connector
Rate this response:  
Not yet rated
chulett

Premium Poster


since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 42268
Location: Denver, CO
Points: 217033

Post Posted: Thu Feb 18, 2016 7:26 pm Reply with quote    Back to top    

Ah... I see our old friend Vincent is still hard at work over there. Wink

_________________
-craig

Watch out where the huskies go and don't you eat that yellow snow
Rate this response:  
Not yet rated
kduke

Premium Poster


since February 2006

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 29 May 2003
Posts: 5227
Location: Dallas, TX
Points: 35013

Post Posted: Thu Feb 18, 2016 9:16 pm Reply with quote    Back to top    

In one of the releases they converted these to the recommended stages as they imported the jobs. You might try exporting and importing and see if it upgrades your jobs. Save you a lot of time fixing t ...

_________________
Mamu Kim
Rate this response:  
Not yet rated
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54070
Location: Sydney, Australia
Points: 293276

Post Posted: Sun Feb 21, 2016 3:48 pm Reply with quote    Back to top    

It's called the Connector Migration Tool, and is mentioned in the error messages. Another change in 11.x is that HTTP for connecting is no longer supported. People seem to have taken that one in ...

_________________
RXP Services Ltd
Melbourne | Canberra | Sydney | Hong Kong | Hobart | Brisbane
currently hiring: Canberra, Sydney and Melbourne
Rate this response:  
Not yet rated
rkashyap



Group memberships:
Premium Members

Joined: 02 Dec 2011
Posts: 498
Location: Richmond VA
Points: 4518

Post Posted: Wed Feb 24, 2016 8:55 am Reply with quote    Back to top    

Another change in DataStage 11.5 ... Some of the ODBC drivers which were deprecated in previous versions have now been retired.
Rate this response:  
Not yet rated
vmcburney

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup

Joined: 23 Jan 2003
Posts: 3564
Location: Australia, Melbourne
Points: 27712

Post Posted: Wed Feb 24, 2016 9:37 pm Reply with quote    Back to top    

You want to move away from the OCI stage to the Connector stage because IBM are no longer upgrading and certifying the OCI stages against new versions of databases. If you want to keep up to date with the latest Oracle or SQL Server then it's best to use the Connector Migration Wizard to convert all your jobs across to Connectors. There are some benefits to Connectors, I believe they are a bit faster and they have much better reject handling for things like foreign key or primary key violations.

_________________
Certus Solutions
Blog: Tooling Around in the InfoSphere
Twitter: @vmcburney
LinkedIn: Vincent McBurney LinkedIn
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours