DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
kdimitri
Participant



Joined: 19 May 2006
Posts: 1

Points: 23

Post Posted: Tue May 23, 2006 9:10 am Reply with quote    Back to top    

DataStage® Release: 7x
Job Type: Server
OS: Windows
I have a problem while executing a data validation map with an XML file. The Command Server window shows me the right number of objects traited for the input but there is no output and the message is :"One or more inputs was invalid".

I execute the map another time, but with a trace and now I can read in the trace : "INPUT 1 was valid.". And I still have my error message in my Command Server window...

The interesting thing is that when I look at the more detailed trace, I can see this type of message :

External Parser returned Error:
TYPE X'0002' (Error (-9), "XMLParser: Could not find type to assign XML data."
No type to assign mixed data was found
[element name: ListeFluxInteret, namespace: , current input data offset: 74129]

Error (-9), "XMLParser: Could not find type to assign XML data."
No type to assign mixed data was found
[element name: ListeFluxInteret, namespace: , current input data offset: 1308585]

Error (-9), "XMLParser: Could not find type to assign XML data."
No type to assign ).


I someone could explain me this error and how to correct this, I would be gratefull...
janhess
Participant



Joined: 18 Sep 2003
Posts: 201
Location: UK
Points: 950

Post Posted: Wed May 24, 2006 2:22 am Reply with quote    Back to top    

It looks like a bug. Send it to IBM suport.
Rate this response:  
Not yet rated
manojmmx
Participant



Joined: 09 May 2006
Posts: 8
Location: Pune
Points: 84

Post Posted: Tue May 30, 2006 4:17 am Reply with quote    Back to top    

I guess you need to place the DTD or Schema (from which you imported your Tree) at correct path with respect to your executable map.
The compiled map has reference to the schema/DTD, check at DOC element's properties : Intent >Validate As> Metadata Location. You need to keep the xsd or dtd at this path.
Let me know if this works.
Rate this response:  
Not yet rated
zamzam
Participant



Joined: 29 Apr 2011
Posts: 4
Location: Luxembourg
Points: 63

Post Posted: Fri Apr 29, 2011 10:24 am Reply with quote    Back to top    

i have exactly the same problem.
I imported an XSD A containing a namespace to an other XSD B
Import was successful, and i got 1 tree containing both tags

When i compile, all is ok but when i execute the map there is an error.

I check DOC element's properties and it has the good XSD A location.

I found nowhere a link to the XSD B ... and the tag in the error message is declared in XSD B


I think there is a critical bug somewhere ...
Rate this response:  
Not yet rated
blewip
Participant



Joined: 10 Nov 2004
Posts: 81
Location: London
Points: 566

Post Posted: Tue May 03, 2011 2:07 am Reply with quote    Back to top    

kdimitri wrote:

I someone could explain me this error and how to correct this, I would be gratefull...


It just looks like the XML file does not match the type tree.

How did you generate the type tree, from XSD or DTD?

Does the XML file validate against the XSD?

Are you using the ability to do XSD validation at run time, I wasn't sure if your version 7.x has this ability?

_________________
Modern Life is Rubbish - Blur
Rate this response:  
Not yet rated
zamzam
Participant



Joined: 29 Apr 2011
Posts: 4
Location: Luxembourg
Points: 63

Post Posted: Tue May 03, 2011 2:21 am Reply with quote    Back to top    

for me :
-WTX version 8.3.0.2
-right click-> validation on XML in WTX is ok
-import from XSDs with Xerces
Rate this response:  
Not yet rated
blewip
Participant



Joined: 10 Nov 2004
Posts: 81
Location: London
Points: 566

Post Posted: Tue May 03, 2011 3:42 am Reply with quote    Back to top    

zamzam wrote:
for me :
-WTX version 8.3.0.2
-right click-> validation on XML in WTX is ok
-import from XSDs with Xerces


Not sure that your issue is the same, for instance you have version 8 and you are using Xerces. I'm not sure this functionality is there in the version the original issue was posted.

Post your error, or better still post a new issue if it appears to be different

_________________
Modern Life is Rubbish - Blur
Rate this response:  
Not yet rated
zamzam
Participant



Joined: 29 Apr 2011
Posts: 4
Location: Luxembourg
Points: 63

Post Posted: Tue May 03, 2011 4:10 am Reply with quote    Back to top    

ok

now it is here : http://www.dsxchange.com/viewtopic.php?p=395687#395687

_________________
why make standards if we always change them ?
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours