DSXchange: DataStage and IBM Websphere Data Integration Forum
View next topic
View previous topic
Add To Favorites
Author Message
bikan



Group memberships:
Premium Members

Joined: 08 Jun 2006
Posts: 128

Points: 1241

Post Posted: Wed Jun 03, 2009 7:19 am Reply with quote    Back to top    

DataStage® Release: 7x
Job Type: Parallel
OS: Unix
Hi All,

My jobs looks like
External Source ===> XML input stage ===> output file

I am not getting any warning or fatal error in director then also data is not getting generated in output file.

If i am adding namespace declaration and keeping their ref value in xpath expression then job is running w/o warning but i not not getting data loaded in sequential file(output).
and after removing namespace declaration and their corresponding ref value from xpath i am getting proper output(data) in sequential file.

Pls suggest solution.

Thanks in advance

Murari
ArndW

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup

Joined: 16 Nov 2004
Posts: 16318
Location: Germany
Points: 92566

Post Posted: Wed Jun 03, 2009 7:57 am Reply with quote    Back to top    

I'm not in a position to check and don't remember the details, but I recall about a year ago we had issues with XML namespace definitions and installed an IBM patch that addressed the problem.

_________________

Image
Rate this response:  
Not yet rated
bikan



Group memberships:
Premium Members

Joined: 08 Jun 2006
Posts: 128

Points: 1241

Post Posted: Wed Jun 03, 2009 9:54 pm Reply with quote    Back to top    

ArndW wrote:
I'm not in a position to check and don't remember the details, but I recall about a year ago we had issues with XML namespace definitions and installed an IBM patch that addressed the problem.


Hi ArndW

Thanks for your response...
Can u elaborate on the details about IBM patch or location of all the IBM patches available for XML..

Thanks in advance
Murari
Rate this response:  
Not yet rated
ray.wurlod

Premium Poster
Participant

Group memberships:
Premium Members, Inner Circle, Australia Usergroup, Server to Parallel Transition Group

Joined: 23 Oct 2002
Posts: 54570
Location: Sydney, Australia
Points: 295936

Post Posted: Wed Jun 03, 2009 10:08 pm Reply with quote    Back to top    

Which part of this statement is unclear?
arndw wrote:
I'm not in a position to check and don't remember the details

_________________
IBM Software Services Group
Any contribution to this forum is my own opinion and does not necessarily reflect any position that IBM may hold.
Rate this response:  
Not yet rated
bikan



Group memberships:
Premium Members

Joined: 08 Jun 2006
Posts: 128

Points: 1241

Post Posted: Wed Jun 03, 2009 10:18 pm Reply with quote    Back to top    

ray.wurlod wrote:
Which part of this statement is unclear?
arndw wrote:
I'm not in a position to check and don't remember the details

Hi..

Actaully i dont know abt the patch available in IBM for XML..
Thats why i wanted to know what does "installed an IBM patch that addressed the problem".

Thanks
Rate this response:  
Not yet rated
chulett

Premium Poster


since January 2006

Group memberships:
Premium Members, Inner Circle, Server to Parallel Transition Group

Joined: 12 Nov 2002
Posts: 43085
Location: Denver, CO
Points: 222463

Post Posted: Wed Jun 03, 2009 11:26 pm Reply with quote    Back to top    

It means that - without further clarification from the forums - you should check with your official support provider and see if this is a known issue with an available patch. I too recall such a thing ...

_________________
-craig

"You can never have too many knives" -- Logan Nine Fingers
Rate this response:  
eostic

Premium Poster



Group memberships:
Premium Members

Joined: 17 Oct 2005
Posts: 3833

Points: 30939

Post Posted: Thu Jun 04, 2009 12:19 am Reply with quote    Back to top    

I don't recall any namespace specific patches for 7, but that doesn't mean there weren't any. Namespaces can be very confusing, especially if you have any default namespaces (without a specific prefix). Those are some of the most confusing, where you will have xmlns="http...." without a prefix value. If you generate the xpath in the xml importer, you should get an NSxx value. This is proper.... but then various mismatches (the namespace info isn't in the detailed property box, or you have xpath that doesn't have the prefix in your description properties on the link, or a document comes in that doesn't use it.....all can result in 0 rows coming out of the Stage. Look carefully at all the possibilities. Worst case, just "zap" out the namespace info in the header before (in an upstream transformer) entering the XMLInput Stage.

Ernie

_________________
Ernie Ostic

blogit!
Open IGC is Here!
Rate this response:  
Not yet rated
Display posts from previous:       

Add To Favorites
View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2002 phpBB Group
Theme & Graphics by Daz :: Portal by Smartor
All times are GMT - 6 Hours